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1 Introduction

Authors wishing to code their contribution with LATEX, as well as those who
have already coded with LATEX, will be provided with a document class that
will give the text the desired layout. Authors are requested to adhere strictly to
these instructions; the class file must not be changed.

The text output area is automatically set within an area of 12.2 cm horizon-
tally and 19.3 cm vertically.

If you are already familiar with LATEX, then the LLNCS class should not give
you any major difficulties. It will change the layout to the required LLNCS style
(it will for instance define the layout of \section). We had to invent some extra
commands, which are not provided by LATEX (e.g. \institute, see also Sect. 5)

For the main body of the paper (the text) you should use the commands of the
standard LATEX “article” class. Even if you are familiar with those commands,
we urge you to read this entire documentation thoroughly. It contains many
suggestions on how to use our commands properly; thus your paper will be
formatted exactly to LLNCS standard. For the input of the references at the end
of your contribution, please follow our instructions given in Sect. 17 References.

The majority of these hints are not specific for LLNCS; they may improve
your use of LATEX in general. Furthermore, the documentation provides sugges-
tions about the proper editing and use of the input files (capitalization, abbre-
viation etc.) (see Sect. 4 How to Edit Your Input File).

2 How to Proceed

The package consists of the following files:

history.txt the version history of the package

llncs.cls class file for LATEX

llncs.dem an example showing how to code the text

llncs.doc general instructions (source of this document),
llncs.doc means latex documentation for
Lecture Notes in C omputer Science

llncsdoc.pdf the documentation of the class (PDF version),
llncs.doc general instructions (source of this document),
llncsdoc.sty class modifications to help for the instructions
llncs.ind an external (faked) author index file
subjidx.ind subject index demo from the Springer book package
llncs.dvi the resultig DVI file (remember to use binary transfer!)

sprmindx.sty supplementary style file for MakeIndex
(usage: makeindex -s sprmindx.sty <yourfile.idx>)

2.1 How to Invoke the LLNCS Document Class

The LLNCS class is an extension of the standard LATEX “article” document class.
Therefore you may use all “article” commands for the body of your contribution
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to prepare your manuscript. LLNCS class is invoked by replacing “article” by
“llncs” in the first line of your document:

\documentclass{llncs}

%

\begin{document}

<Your contribution>

\end{document}

2.2 Contributions Already Coded with LATEX without the LLNCS
document class

If your file is already coded with LATEX you can easily adapt it a posteriori to
the LLNCS document class.

Please refrain from using any LATEX or TEX commands that affect the layout
or formatting of your document (i.e. commands like \textheight, \vspace,
\headsep etc.). There may nevertheless be exceptional occasions on which to
use some of them.

The LLNCS document class has been carefully designed to produce the right
layout from your LATEX input. If there is anything specific you would like to do
and for which the style file does not provide a command, please contact us. Same
holds for any error and bug you discover (there is however no reward for this –
sorry).

3 General Rules for Coding Formulas

With mathematical formulas you may proceed as described in Sect. 3.3 of the
LATEX User’s Guide & Reference Manual by Leslie Lamport (2nd ed. 1994),
Addison-Wesley Publishing Company, Inc.

Equations are automatically numbered sequentially throughout your contri-
bution using arabic numerals in parentheses on the right-hand side.

LyX users: Select Insert >Math >Numbered formula from the menu bar.

When you are working in math mode everything is typeset in italics. Some-
times you need to insert non-mathematical elements (e.g. words or phrases).
Such insertions should be coded in roman (with \mbox) as illustrated in the
following example:

Sample Input

\begin{equation}

\left(\frac{a^{2} + b^{2}}{c^{3}} \right) = 1 \quad

\mbox{ if } c\neq 0 \mbox{ and if } a,b,c\in \bbbr \enspace .

\end{equation}
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Sample Output (
a2 + b2

c3

)
= 1 if c 6= 0 and if a, b, c ∈ IR . (1)

If you wish to start a new paragraph immediately after a displayed equation,
insert a blank line so as to produce the required indentation. If there is no
new paragraph either do not insert a blank line or code \noindent immediately
before continuing the text.

LyX users: Select Edit >Paragraph Settings... from the menu bar orright-click
the paragraph and select Paragraph Settings.... Uncheck Indent paragraph.

Please punctuate a displayed equation in the same way as other ordinary
text but with an \enspace before end punctuation. See an example here.

Note that the sizes of the parentheses or other delimiter symbols used in
equations should ideally match the height of the formulas being enclosed. This
is automatically taken care of by the following LATEX commands:

\left( or \left[ and \right) or \right].

LyX users: Insert parentheses and other delimiter symbols using the toolbar
at the bottom of the LyX window. It is useful to toogle a panel with additional
math symbols – select View >Toolbars >Math Panels (auto) from the menu bar
(you may also want to choose additional toolbars available under Other Toolbars
for a quick access to frequently used symbols).

3.1 Italic and Roman Type in Math Mode

a) In math mode LATEX treats all letters as though they were mathematical
or physical variables, hence they are typeset as characters of their own in
italics. However, for certain components of formulas, like short texts, this
would be incorrect and therefore coding in roman is required. Roman should
also be used for subscripts and superscripts in formulas where these are
merely labels and not in themselves variables, e.g. Teff not Teff , TK not TK
(K = Kelvin), me not me (e = electron). However, do not code for roman
if the sub/superscripts represent variables, e.g.

∑n
i=1 ai. See here for more

information.
b) Please ensure that physical units (e.g. pc, erg s−1 K, cm−3, W m−2 Hz−1,

m kg s−2 A−2) and abbreviations such as Ord, Var, GL, SL, sgn, const.
are always set in roman type. To ensure this use the \mathrm command:
\mathrm{Hz}.

LyX users: Select Fonts >Normal text mode from the toolbar at the bottom
of the LyX window.

On p. 44 of the LATEX User’s Guide & Reference Manual by Leslie Lamport
you will find the names of common mathematical functions, such as log, sin,

http://physik.kfunigraz.ac.at/itp/iutp/macros/lamuphys.dem
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exp, max and sup. These should be coded as \log, \sin, \exp, \max, \sup
and will appear in roman automatically.

LyX users: Select the appropriate function in Functions from the bottom
toolbar.

c) Chemical symbols and formulas should be coded for roman, e.g. Fe not Fe,
H2O not H2O.

d) Familiar foreign words and phrases, e.g. et al., a priori, in situ, bremsstrah-
lung, eigenvalues should not be italicized.

4 How to Edit Your Input (Source) File

4.1 Headings

All words in headings should be capitalized except for conjunctions, prepositions
(e.g. on, of, by, and, or, but, from, with, without, under) and definite and indef-
inite articles (the, a, an) unless they appear at the beginning. Formula letters
must be typeset as in the text.

4.2 Capitalization and Non-capitalization

a) The following should always be capitalized:

– Headings (see preceding Sect. 4.1)
– Abbreviations and expressions in the text such as Fig(s)., Table(s),

Sect(s)., Chap(s)., Theorem, Corollary, Definition etc. when used with
numbers, e.g. Fig. 3, Table 1, Theorem 2.

Please follow the special rules in Sect. 4.3 for referring to equations.
b) The following should not be capitalized:

– The words figure(s), table(s), equation(s), theorem(s) in the text when
used without an accompanying number.

– Figure legends and table captions except for names and abbreviations.

4.3 Abbreviation of Words

a) The following should be abbreviated when they appear in running text unless
they come at the beginning of a sentence: Chap., Sect., Fig.; e.g. The results
are depicted in Fig. 5. Figure 9 reveals that ....
Please note: Equations should usually be referred to solely by their number in
parentheses: e.g. (14). However, when the reference comes at the beginning of
a sentence, the unabbreviated word “Equation” should be used: e.g. Equation
(14) is very important. However, (15) makes it clear that ....

b) If abbreviations of names or concepts are used throughout the text, they
should be defined at first occurrence, e.g. Plurisubharmonic (PSH) Func-
tions, Strong Optimization (SOPT) Problem.
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5 How to Code the Beginning of Your Contribution

The title of a single contribution (it is mandatory) should be coded as follows:

\title{<Your contribution title>}

All words in titles should be capitalized except for conjunctions, prepositions
(e.g. on, of, by, and, or, but, from, with, without, under) and definite and indef-
inite articles (the, a, an) unless they appear at the beginning. Formula letters
must be typeset as in the text. Titles have no end punctuation.

LyX users: Change the environment to Title.

If a long \title must be divided please use the code \\ (for new line).

LyX users: To divide a title, place the cursor in the desired position and press
Ctrl+Enter.

If you are to produce running heads for a specific volume the standard (of
no such running heads) is overwritten with the [runningheads] option in the
\documentclass line. For long titles that do not fit in the single line of the
running head a warning is generated.

LyX users: Go to Document >Settings >Document Class. In Class Options
group, type runningheads in the Custom text field. If after generating a PDF
document you will see Title Suppressed Due to Excessive Length instead of the
real title (on top of each odd page), it means the title is too long.

You can specify an abbreviated title for the running head on odd pages with
the command

\titlerunning{<Your abbreviated contribution title>}

LyX users: Change the environment to Running LaTeX Title.

There is also a possibility to change the text of the title that goes into the
table of contents (that’s for volume editors only – there is no table of contents
for a single contribution). For this use the command

\toctitle{<Your changed title for the table of contents>}

LyX users: Change the environment to TOC Title.

An optional subtitle may follow then:

\subtitle{<subtitle of your contribution>}

LyX users: Change the environment to Subtitle.

Now the name(s) of the author(s) must be given:

\author{<author(s) name(s)>}
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Numbers referring to different addresses or affiliations are to be attached to each
author with the \inst{<no>} command. If there is more than one author, the
order is up to you; the \and command provides for the separation.

LyX users: Change the environment to Author. Insert \inst{<no>} and \and

commands where appropriate.

If you have done this correctly, this entry now reads, for example:

\author{Ivar Ekeland\inst{1} \and Roger Temam\inst{2}}

The first name1 is followed by the surname.
As for the title there exist two additional commands (again for volume editors

only) for a different author list. One for the running head (on odd pages) – if
there is any:

\authorrunning{<abbreviated author list>}

And one for the table of contents where the affiliation of each author is simply
added in braces.

\tocauthor{<enhanced author list for the table of contents>}

LyX users: Change the environment to Author Running or TOC Author re-
spectively.

Next the address(es) of institute(s), company etc. is (are) required. If there
is more than one address, the entries are numbered automatically with \and, in
the order in which you type them. Please make sure that the numbers match
those placed next to to the authors’ names to reflect the affiliation.

\institute{<name of an institute>

\and <name of the next institute>

\and <name of the next institute>}

LyX users: Change the environment to Institute. Insert \and to delimit insti-
tutes.

In addition, you can use

\email{<email address>}

to provide your email address within \institute. If you need to typeset the
tilde character – e.g. for your web page in your unix system’s home directory
– the \homedir command will happily do this. Please note that, if your email
address is given in your paper, it will also be included in the meta data of the
online version.

LyX users: To provide an email, insert \email{<email address>} command.

If footnote like things are needed anywhere in the contribution heading please
code (immediately after the word where the footnote indicator should be placed):

1 Other initials are optional and may be inserted if this is the usual way of writing
your name, e.g. Alfred J. Holmes, E. Henry Green.
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\thanks{<text>}

\thanks may only appear in \title, \author and \institute to footnote any-
thing. If there are two or more footnotes or affiliation marks to a specific item
separate them with \fnmsep (i.e. footnote mark separator).

LyX users: To provide such a footnote, insert \thanks{<text>} command.

The command

\maketitle

then formats the complete heading of your article. If you leave it out the work
done so far will produce no text.

LyX users: LyX adds the \maketitle command automatically.

Then the abstract should follow. Simply code

\begin{abstract}

<Text of the summary of your article>

\end{abstract}

or refer to the demonstration file llncs.dem for an example or to the Sample
Input on p. 14.

LyX users: Change the environment to Abstract.

Remark to Running Heads and the Table of Contents

If you are the author of a single contribution you normally have no running
heads and no table of contents. Both are done only by the editor of the volume
or at the printers.

6 Special Commands for the Volume Editor

The volume editor can produce a complete camera ready output including run-
ning heads, a table of contents, preliminary text (frontmatter), and index or glos-
sary. For activating the running heads there is the class option [runningheads].

The table of contents of the volume is printed wherever \tableofcontents is
placed. A simple compilation of all contributions (fields \title and \author) is
done. If you wish to change this automatically produced list use the commands

\titlerunning \toctitle

\authorrunning \tocauthor

to enhance the information in the specific contributions. See the demonstration
file llncs.dem for examples.
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An additional structure can be added to the table of contents with the
\addtocmark{<text>} command. It has an optional numerical argument, a digit
from 1 through 3. 3 (the default) makes an unnumbered chapter like entry in the
table of contents. If you code \addtocmark[2]{text} the corresponding page
number is listed also, \addtocmark[1]{text} even introduces a chapter number
beyond it.

LyX users: To add an additional structure, insert the appropriate command:
\addtocmark{<text>}, \addtocmark[1]{<text>}, \addtocmark[2]{<text>}.

7 How to Code Your Text

The contribution title and all headings should be capitalized except for conjunc-
tions, prepositions (e.g. on, of, by, and, or, but, from, with, without, under) and
definite and indefinite articles (the, a, an) unless they appear at the beginning.
Formula letters must be typeset as in the text.

Headings will be automatically numbered by the following codes.

Sample Input

\section{This is a First-Order Title}

\subsection{This is a Second-Order Title}

\subsubsection{This is a Third-Order Title.}

\paragraph{This is a Fourth-Order Title.}

\section and \subsection have no end punctuation.
\subsubsection and \paragraph need to be punctuated at the end.

LyX users: Change the environment to the respective one from Sectioning
group.

In addition to the above-mentioned headings your text may be structured by
subsections indicated by run-in headings (theorem-like environments). All the
theorem-like environments are numbered automatically throughout the sections
of your document – each with its own counter. If you want the theorem-like
environments to use the same counter just specify the documentclass option
envcountsame:

\documentclass[envcountsame]{llncs}

If your first call for a theorem-like environment then is e.g. \begin{lemma}, it
will be numbered 1; if corollary follows, this will be numbered 2; if you then call
lemma again, this will be numbered 3.

LyX users: Go to Document >Settings >Document Class. In Class Options
group, type envcountsame in the Custom text field.

But in case you want to reset such counters to 1 in each section, please specify
the documentclass option envcountreset:
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\documentclass[envcountreset]{llncs}

LyX users: Go to Document >Settings >Document Class. In Class Options
group, type envcountreset in the Custom text field.

Even a numbering on section level (including the section counter) is possible
with the documentclass option envcountsect.

LyX users: Go to Document >Settings >Document Class. In Class Options
group, type envcountsect in the Custom text field.

8 Predefined Theorem like Environments

The following variety of run-in headings are at your disposal:

a) Bold run-in headings with italicized text as built-in environments:

\begin{corollary} <text> \end{corollary}

\begin{lemma} <text> \end{lemma}

\begin{proposition} <text> \end{proposition}

\begin{theorem} <text> \end{theorem}

b) The following generally appears as italic run-in heading:

\begin{proof} <text> \qed \end{proof}

It is unnumbered and may contain an eye catching square (call for that with
\qed) before the environment ends.

c) Further italic or bold run-in headings with roman environment body may
also occur:

\begin{definition} <text> \end{definition}

\begin{example} <text> \end{example}

\begin{exercise} <text> \end{exercise}

\begin{note} <text> \end{note}

\begin{problem} <text> \end{problem}

\begin{question} <text> \end{question}

\begin{remark} <text> \end{remark}

\begin{solution} <text> \end{solution}

9 Defining your Own Theorem like Environments

We have enhanced the standard \newtheorem command and slightly changed
its syntax to get two new commands \spnewtheorem and \spnewtheorem* that
now can be used to define additional environments. They require two additional
arguments namely the type style in which the keyword of the environment ap-
pears and second the style for the text of your new environment.

LyX users: It is possible to define own theorem-like environments only by
means of inserted LATEX code.

\spnewtheorem can be used in two ways.
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9.1 Method 1 (preferred)

You may want to create an environment that shares its counter with another
environment, say main theorem to be numbered like the predefined theorem. In
this case, use the syntax

\spnewtheorem{<env_nam>}[<num_like>]{<caption>}

{<cap_font>}{<body_font>}

Here the environment with which the new environment should share its counter
is specified with the optional argument [<num_like>].

Sample Input

\spnewtheorem{mainth}[theorem]{Main Theorem}{\bfseries}{\itshape}

\begin{theorem} The early bird gets the worm. \end{theorem}

\begin{mainth} The early worm gets eaten. \end{mainth}

Sample Output

Theorem 3. The early bird gets the worm.

Main Theorem 4. The early worm gets eaten.

The sharing of the default counter ([theorem]) is desired. If you omit the
optional second argument of \spnewtheorem a separate counter for your new
environment is used throughout your document.

9.2 Method 2 (assumes [envcountsect] documentstyle option)

\spnewtheorem{<env_nam>}{<caption>}[<within>]

{<cap_font>}{<body_font>}

This defines a new environment <env_nam> which prints the caption <caption>

in the font <cap_font> and the text itself in the font <body_font>. The en-
vironment is numbered beginning anew with every new sectioning element you
specify with the optional parameter <within>.

Example

\spnewtheorem{joke}{Joke}[subsection]{\bfseries}{\rmfamily}

defines a new environment called joke which prints the caption Joke in boldface
and the text in roman. The jokes are numbered starting from 1 at the beginning
of every subsection with the number of the subsection preceding the number of
the joke e.g. 7.2.1 for the first joke in subsection 7.2.
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9.3 Unnumbered Environments

If you wish to have an unnumbered environment, please use the syntax

\spnewtheorem*{<env_nam>}{<caption>}{<cap_font>}{<body_font>}

10 Program Codes

In case you want to show pieces of program code, just use the verbatim en-
vironment or the verbatim package of LATEX. (There also exist various pretty
printers for some programming languages.)

LyX users: To show pieces of program code, change the environment to Verba-
tim. To change the style back to the regular one, select Standard environment.

Sample Input (of a simple contribution)

\title{Hamiltonian Mechanics}

\author{Ivar Ekeland\inst{1} \and Roger Temam\inst{2}}

\institute{Princeton University, Princeton NJ 08544, USA

\and

Universit\’{e} de Paris-Sud,

Laboratoire d’Analyse Num\’{e}rique, B\^{a}timent 425,\\

F-91405 Orsay Cedex, France}

\maketitle

%

\begin{abstract}

This paragraph shall summarize the contents of the paper

in short terms.

\end{abstract}

%

\section{Fixed-Period Problems: The Sublinear Case}

%

With this chapter, the preliminaries are over, and we begin the

search for periodic solutions \dots

%

\subsection{Autonomous Systems}

%

In this section we will consider the case when the Hamiltonian

$H(x)$ \dots

%

\subsubsection*{The General Case: Nontriviality.}

%
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We assume that $H$ is

$\left(A_{\infty}, B_{\infty}\right)$-subqua\-dra\-tic

at infinity, for some constant \dots

%

\paragraph{Notes and Comments.}

The first results on subharmonics were \dots

%

\begin{proposition}

Assume $H’(0)=0$ and $ H(0)=0$. Set \dots

\end{proposition}

\begin{proof}[of proposition]

Condition (8) means that, for every $\delta’>\delta$, there is

some $\varepsilon>0$ such that \dots \qed

\end{proof}

%

\begin{example}[\rmfamily (External forcing)]

Consider the system \dots

\end{example}

\begin{corollary}

Assume $H$ is $C^{2}$ and

$\left(a_{\infty}, b_{\infty}\right)$-subquadratic

at infinity. Let \dots

\end{corollary}

\begin{lemma}

Assume that $H$ is $C^{2}$ on $\bbbr^{2n}\backslash \{0\}$

and that $H’’(x)$ is \dots

\end{lemma}

\begin{theorem}[(Ghoussoub-Preiss)]

Let $X$ be a Banach Space and $\Phi:X\to\bbbr$ \dots

\end{theorem}

\begin{definition}

We shall say that a $C^{1}$ function $\Phi:X\to\bbbr$

satisfies \dots

\end{definition}

Sample Output (follows on the next page together with examples of the above
run-in headings)



Hamiltonian Mechanics

Ivar Ekeland1 and Roger Temam2

1 Princeton University, Princeton NJ 08544, USA
2 Université de Paris-Sud, Laboratoire d’Analyse Numérique, Bâtiment 425,

F-91405 Orsay Cedex, France

Abstract. This paragraph shall summarize the contents of the paper in
short terms.

1 Fixed-Period Problems: The Sublinear Case

With this chapter, the preliminaries are over, and we begin the search for periodic
solutions ...

1.1 Autonomous Systems

In this section we will consider the case when the Hamiltonian H(x) ...

The General Case: Nontriviality. We assume that H is (A∞, B∞)-subqua-
dratic at infinity, for some constant ...

Notes and Comments. The first results on subharmonics were ...

Proposition 1. Assume H ′(0) = 0 and H(0) = 0. Set ...

Proof (of proposition). Condition (8) means that, for every δ′ > δ, there is some
ε > 0 such that ... ut

Example 1 (External forcing). Consider the system ...

Corollary 1. Assume H is C2 and (a∞, b∞)-subquadratic at infinity. Let ...

Lemma 1. Assume that H is C2 on IR2n\{0} and that H ′′(x) is ...

Theorem 1 (Ghoussoub-Preiss). Let X be a Banach Space and Φ : X → IR
...

Definition 1. We shall say that a C1 function Φ : X → IR satisfies ...
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11 Fine Tuning of the Text

The following should be used to improve the readability of the text:

\, a thin space, e.g. between numbers or between units and num-
bers; a line division will not be made following this space

-- en dash; two strokes, without a space at either end
 -- en dash; two strokes, with a space at either end
- hyphen; one stroke, no space at either end
$-$ minus, in the text only

Input 21\,$^{\circ}$C etc.,

Dr h.\,c.\,Rockefellar-Smith \dots

20,000\,km and Prof.\,Dr Mallory \dots

1950--1985 \dots

this -- written on a computer -- is now printed

$-30$\,K \dots

Output 21 ◦C etc., Dr h. c. Rockefellar-Smith ...
20,000 km and Prof. Dr Mallory ...
1950–1985 ...
this – written on a computer – is now printed
−30 K ...

LyX users: To typeset eg. physical quantities, like −30 K, use inline math
formulas available under Insert >Math >Inline formula from the menu bar.
Such a formula corresponds to $...$ in LATEX.

12 Special Typefaces

Normal type (roman text) need not be coded. Italic ({\em <text>} better still
\emph{<text>}) or, if necessary, boldface should be used for emphasis.

{\itshape Text} Italicized Text

{\em Text} Emphasized Text – if you would like to emphasize a defini-
tion within an italicized text (e.g. of a theorem) you should
code the expression to be emphasized by \em.

{\bfseries Text} Important Text

\vec{Symbol} Vectors may only appear in math mode. The default LATEX
vector symbol has been adapted3 to LLNCS conventions.

$\vec{A \times B\cdot C} yields A × B · C
$\vec{A}^{T} \otimes \vec{B} \otimes

\vec{\hat{D}}$yields AT ⊗B ⊗ D̂
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LyX users: Select a piece of the text you want to format. Select Edit >Text
Style >Customized... orright-click on the selected text and select Text Style
>Customized....

– To make text italicized, select Italic from Shape combo box.

– To make text boldfaced, select Bold from Series combo box.

– To remove text formatting, select No change from the respective combo box.

To toggle the text emphasis, select a piece of text and press Ctrl+E.

3 If you absolutely must revive the original LATEX design of the vector symbol (as an
arrow accent), please specify the option [orivec] in the documentclass line.
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13 Footnotes

Footnotes within the text should be coded:

\footnote{Text}

Sample Input

Text with a footnote\footnote{The footnote is automatically

numbered.} and text continues ...

Sample Output

Text with a footnote4 and text continues ...

LyX users: To insert a footnote, select Insert >Footnote from the menu bar.

14 Lists

Please code lists as described below:

Sample Input

\begin{enumerate}

\item First item

\item Second item

\begin{enumerate}

\item First nested item

\item Second nested item

\end{enumerate}

\item Third item

\end{enumerate}

Sample Output

1. First item
2. Second item

(a) First nested item
(b) Second nested item

3. Third item

LyX users: To insert a list, select Numbered list from the top toolbar. Use Tab

and Alt+Tab to promote or demote one level, respectively. To insert break a line
within a list item, select Insert >Formatting >Ragged Line Break.

4 The footnote is automatically numbered.
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15 Figures

Figure environments should be inserted after (not in) the paragraph in which
the figure is first mentioned. They will be numbered automatically.

Preferably the images should be enclosed as PostScript files – best as EPS
data using the epsfig package.

If you cannot include them into your output this way and use other tech-
niques for a separate production, the figures (line drawings and those containing
halftone inserts as well as halftone figures) should not be pasted into your laser-
printer output. They should be enclosed separately in camera-ready form (orig-
inal artwork, glossy prints, photographs and/or slides). The lettering should be
suitable for reproduction, and after a probably necessary reduction the height
of capital letters should be at least 1.8 mm and not more than 2.5 mm. Check
that lines and other details are uniformly black and that the lettering on figures
is clearly legible.

To leave the desired amount of space for the height of your figures, please use
the coding described below. As can be seen in the output, we will automatically
provide 1 cm space above and below the figure, so that you should only leave
the space equivalent to the size of the figure itself. Please note that “x” in the
following coding stands for the actual height of the figure:

\begin{figure}

\vspace{x cm}

\caption[ ]{...text of caption...} (Do type [ ])

\end{figure}

Sample Input

\begin{figure}

\vspace{2.5cm}

\caption{This is the caption of the figure displaying a white

eagle and a white horse on a snow field}

\end{figure}

Sample Output

Fig. 1. This is the caption of the figure displaying a white eagle and a white horse on
a snow field
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LyX users: To insert a figure, choose Insert >Float >Figure from the menu
bar. To leave the desired amount of space for the height of your figures, move the
cursor before ,,Figure” text and choose Insert >Formatting >Vertical space...
from the menu bar. In the vspace dialog choose Spacing: Custom and Value:
x cm.

To provide an actual image, choose Insert >Graphics... from the menu bar.
Browse for an image file and then specify image height (check the checkbox,
provide the desired value). If you prefer your figure to be centered, click with
RMB on the paragraph containing the image (eg. to the right of the image),
select Paragraph Settings, in Alignment group choose Centered and click OK.

Use relative paths to images. Put image files in a separate directory (eg. figures)
kept in the same directory as the LyX document.

16 Tables

Table captions should be treated in the same way as figure legends, except that
the table captions appear above the tables. The tables will be numbered auto-
matically.

LyX users: To insert a table container, select Insert >Float >Table from the
menu bar. In the paragraph below the caption insert the actual table by selecting
Insert >Table... from the menu bar.

16.1 Tables Coded with LATEX

Please use the following coding:

Sample Input

\begin{table}

\caption{Critical $N$ values}

\begin{tabular}{llllll}

\hline\noalign{\smallskip}

${\mathrm M}_\odot$ & $\beta_{0}$ & $T_{\mathrm c6}$ & $\gamma$

& $N_{\mathrm{crit}}^{\mathrm L}$

& $N_{\mathrm{crit}}^{\mathrm{Te}}$\\

\noalign{\smallskip}

\hline

\noalign{\smallskip}

30 & 0.82 & 38.4 & 35.7 & 154 & 320 \\

60 & 0.67 & 42.1 & 34.7 & 138 & 340 \\

120 & 0.52 & 45.1 & 34.0 & 124 & 370 \\

\hline

\end{tabular}

\end{table}
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Sample Output

Table 1. Critical N values

M� β0 Tc6 γ NL
crit NTe

crit

30 0.82 38.4 35.7 154 320

60 0.67 42.1 34.7 138 340

120 0.52 45.1 34.0 124 370

Before continuing your text you need an empty line. ...

For further information you will find a complete description of the tabular
environment on p. 62 ff. and p. 204 of the LATEX User’s Guide & Reference
Manual by Leslie Lamport.

LyX users: To make a table conformed with LNCS format, first select all
table’s cells and click Unset all lines from the table’s toolbar at the bottom of
LyX window. Then, select the top row of cells and click Set top line and Set
bottom line from the table’s toolbar. Similarily, select the bottom row of cells
and click Set bottom line. Finally, before submitting your manuscript in .tex

format, make sure to insert \noalign{\smallskip} commands in the proper
places in the LATEX code as shown in the Sample Input above.

16.2 Tables Not Coded with LATEX

If you do not wish to code your table using LATEX but prefer to have it reproduced
separately, proceed as for figures and use the following coding:

Sample Input

\begin{table}

\caption{text of your caption}

\vspace{x cm} % the actual height needed for your table

\end{table}

16.3 Signs and Characters

Special Signs. You may need to use special signs. The available ones are listed
in the LATEX User’s Guide & Reference Manual by Leslie Lamport, pp. 41 ff. We
have created further symbols for math mode (enclosed in $):

\grole yields >< \getsto yields ←→
\lid yields <

= \gid yields >
=
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Gothic (Fraktur). If gothic letters are necessary, please use those of the rel-
evant AMS-TEX alphabet which are available using the amstex package of the
American Mathematical Society.

In LATEX only the following gothic letters are available: $\Re$ yields < and
$\Im$ yields =. These should not be used when you need gothic letters for
your contribution. Use AMS-TEX gothic as explained above. For the real and
the imaginary parts of a complex number within math mode you should use
instead: $\mathrm{Re}$ (which yields Re) or $\mathrm{Im}$ (which yields Im).

Script. For script capitals use the coding

$\mathcal{AB}$ which yields AB

(see p. 42 of the LATEX book).

LyX users: Select Fonts >Calligraphic from the formula toolbar (at the bottom
of LyX window).

Special Roman. If you need other symbols than those below, you could use the
blackboard bold characters of AMS-TEX, but there might arise capacity prob-
lems in loading additional AMS-TEX fonts. Therefore we created the blackboard
bold characters listed below. Some of them are not esthetically satisfactory. This
need not deter you from using them: in the final printed form they will be re-
placed by the well-designed MT (monotype) characters of the phototypesetting
machine.

\bbbc (complex numbers) yields C \bbbf (blackboard bold F) yields IF
\bbbh (blackboard bold H) yields IH \bbbk (blackboard bold K) yields IK
\bbbm (blackboard bold M) yields IM \bbbn (natural numbers N) yields IN
\bbbp (blackboard bold P) yields IP \bbbq (rational numbers) yields Q
\bbbr (real numbers) yields IR \bbbs (blackboard bold S) yields S
\bbbt (blackboard bold T) yields T \bbbz (whole numbers) yields ZZ
\bbbone (symbol one) yields 1l

CCC

⊗ IFIFIF ⊗ IHIHIH ⊗ IKIKIK ⊗ IMIMIM

⊗ INININ ⊗ IPIPIP

⊗QQQ
⊗ IRIRIR

⊗ SSS ⊗ TTT

⊗ ZZ ⊗ 1l1l1l

17 References

There are three reference systems available; only one, of course, should be used
for your contribution. With each system (by number only, by letter-number
or by author-year) a reference list containing all citations in the text, should
be included at the end of your contribution placing the LATEX environment
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thebibliography there. For an overall information on that environment see
the LATEX User’s Guide & Reference Manual by Leslie Lamport, p. 71.

There is a special BibTEX style for LLNCS that works along with the class:
splncs.bst – call for it with a line \bibliographystyle{splncs}. If you plan
to use another BibTEX style you are customed to, please specify the option
[oribibl] in the documentclass line, like:

\documentclass[oribibl]{llncs}

This will retain the original LATEX code for the bibliographic environment and
the \cite mechanism that many BibTEX applications rely on.

LyX users: The appropriate piece of LATEX code (\bibliographystyle{splncs03})
has already been included in the LyXtemplate file.

LyX users: To add a bibliography item, set the environment to Citation. You
may want to change its key to a convenient name (to do so, click on the grey
box representing a bibliography item).
To insert a citation, select Insert >Citation... from the menu bar. In the dialog
box select the desired citation(s), click Add, click OK.
To modify a set of items present in the given citation, click on the citation, select
elements to add/remove, click Add/Delete, click OK.

17.1 References by Letter-Number or by Number Only

References are cited in the text – using the \cite command of LATEX – by number
or by letter-number in square brackets, e.g. [1] or [E1, S2], [P1], according to
your use of the \bibitem command in the thebibliography environment. The
coding is as follows: if you choose your own label for the sources by giving
an optional argument to the \bibitem command the citations in the text are
marked with the label you supplied. Otherwise a simple numbering is done,
which is preferred.

The results in this section are a refined version

of \cite{clar:eke}; the minimality result of Proposition~14

was the first of its kind.

The above input produces the citation: “... refined version of [CE1]; the mini-
mality...”. Then the \bibitem entry of the thebibliography environment should
read:

\begin{thebibliography}{[MT1]}

.

.

\bibitem[CE1]{clar:eke}

Clarke, F., Ekeland, I.:

Nonlinear oscillations and boundary-value problems for
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Hamiltonian systems.

Arch. Rat. Mech. Anal. 78, 315--333 (1982)

.

.

\end{thebibliography}

The complete bibliography looks like this:

References

CE1. Clarke, F., Ekeland, I.: Nonlinear oscillations and boundary-value problems for
Hamiltonian systems. Arch. Rat. Mech. Anal. 78, 315–333 (1982)

CE2. Clarke, F., Ekeland, I.: Solutions périodiques, du période donnée, des équations
hamiltoniennes. Note CRAS Paris 287, 1013–1015 (1978)

MT1. Michalek, R., Tarantello, G.: Subharmonic solutions with prescribed minimal
period for nonautonomous Hamiltonian systems. J. Diff. Eq. 72, 28–55 (1988)

Ta1. Tarantello, G.: Subharmonic solutions for Hamiltonian systems via a ZZp pseu-
doindex theory. Annali di Matematica Pura (to appear)

Ra1. Rabinowitz, P.: On subharmonic solutions of a Hamiltonian system. Comm.
Pure Appl. Math. 33, 609–633 (1980)

Number-Only System. For this preferred system do not use the optional
argument in the \bibitem command: then, only numbers will appear for the
citations in the text (enclosed in square brackets) as well as for the marks in your
bibliography (here the number is only end-punctuated without square brackets).

Subsequent citation numbers in the text are collapsed to ranges. Non-numeric
and undefined labels are handled correctly but no sorting is done.

E.g., \cite{n1,n3,n2,n3,n4,n5,foo,n1,n2,n3,?,n4,n5} – where nx is the
key of the xth \bibitem command in sequence, foo is the key of a \bibitem with
an optional argument, and ? is an undefined reference – gives 1,3,2-5,foo,1-3,?,4,5
as the citation reference.

\begin{thebibliography}{1}

\bibitem {clar:eke}

Clarke, F., Ekeland, I.:

Nonlinear oscillations and boundary-value problems for

Hamiltonian systems.

Arch. Rat. Mech. Anal. 78, 315--333 (1982)

\end{thebibliography}

17.2 Author-Year System

References are cited in the text by name and year in parentheses and should look
as follows: (Smith 1970, 1980), (Ekeland et al. 1985, Theorem 2), (Jones and Jaffe
1986; Farrow 1988, Chap. 2). If the name is part of the sentence only the year
may appear in parentheses, e.g. Ekeland et al. (1985, Sect. 2.1) The reference
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list should contain all citations occurring in the text, ordered alphabetically by
surname (with initials following). If there are several works by the same author(s)
the references should be listed in the appropriate order indicated below:

a) One author: list works chronologically;
b) Author and same co-author(s): list works chronologically;
c) Author and different co-authors: list works alphabetically according to co-

authors.

If there are several works by the same author(s) and in the same year, but which
are cited separately, they should be distinguished by the use of “a”, “b” etc.,
e.g. (Smith 1982a), (Ekeland et al. 1982b).

How to Code Author-Year System. If you want to use this system you have
to specify the option [citeauthoryear] in the documentclass, like:

\documentclass[citeauthoryear]{llncs}

Write your citations in the text explicitly except for the year, leaving that up
to LATEX with the \cite command. Then give only the appropriate year as
the optional argument (i.e. the label in square brackets) with the \bibitem

command(s).

Sample Input

The results in this section are a refined version

of Clarke and Ekeland (\cite{clar:eke}); the minimality result of

Proposition~14 was the first of its kind.

The above input produces the citation: “... refined version of Clarke and Eke-
land (1982); the minimality...”. Then the \bibitem entry of clar:eke in the
thebibliography environment should read:

\begin{thebibliography}{} % (do not forget {})

.

.

\bibitem[1982]{clar:eke}

Clarke, F., Ekeland, I.:

Nonlinear oscillations and boundary-value problems for

Hamiltonian systems.

Arch. Rat. Mech. Anal. 78, 315--333 (1982)

.

.

\end{thebibliography}

Sample Output

References

Clarke, F., Ekeland, I.: Nonlinear oscillations and boundary-value problems for Hamil-
tonian systems. Arch. Rat. Mech. Anal. 78, 315–333 (1982)
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